Build Slicer in Linux.

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Build Slicer in Linux.

Jorge Quintero
Hello Slicer Developers,

I am Jorge Quintero and I am newbie in Slicer.

I am trying to build slicer for develope in Linux. I am following the
instructions of the documentation
(https://www.slicer.org/wiki/Documentation/Nightly/Developers/Build_Instructions#Ubuntu).

I done the following steps:

- Install Cmake 3.7-rc02 from
https://cmake.org/files/v3.7/cmake-3.7.2.tar.gz

- Install Git.

- Install SVN.

When I try to install QT using qt-easy-build, I get the next error:

make[2]: *** No hay ninguna regla para construir el objetivo
'../../WebCore/release/libwebcore.a', necesario para
'../../../../../../lib/libQtWebKit.so.4.9.4'.  Alto.
make[2]: se sale del directorio
'/home/jquintero/Descargas/qt-easy-build-4.8.7/qt-everywhere-opensource-src-4.8.7/src/3rdparty/webkit/Source/WebKit/qt'
Makefile.WebKit:135: fallo en las instrucciones para el objetivo
'sub-WebKit-qt-QtWebKit-pro-install_subtargets-ordered'
make[1]: *** [sub-WebKit-qt-QtWebKit-pro-install_subtargets-ordered] Error 2
make[1]: se sale del directorio
'/home/jquintero/Descargas/qt-easy-build-4.8.7/qt-everywhere-opensource-src-4.8.7/src/3rdparty/webkit/Source'
Makefile:693: fallo en las instrucciones para el objetivo
'sub-webkit-install_subtargets-ordered'
make: *** [sub-webkit-install_subtargets-ordered] Error 2

If I try to install from the download file
(http://download.qt-project.org/official_releases/qt/4.8/4.8.7/qt-everywhere-opensource-src-4.8.7.tar.gz
), I do not find the QT SDK necesary to build Slicer in the next steps.

Could someone help me?

Thanks.

Jorge




---------------------------------------------------------------------------------------------
ADVERTENCIA: Sobre la privacidad y cumplimiento de la Ley de Protección de Datos, acceda a http://www.iac.es/disclaimer.php
WARNING: For more information on privacy and fulfilment of the Law concerning the Protection of Data, consult http://www.iac.es/disclaimer.php?lang=en

_______________________________________________
slicer-devel mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
http://www.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/FAQ
Reply | Threaded
Open this post in threaded view
|

Re: Build Slicer in Linux.

Steve Pieper-2
Hi - 

Did you see Fernando's post about adding webkit to the ubuntu instructions?  That may work for you.

https://www.slicer.org/wiki/Documentation/Nightly/Developers/Build_Instructions#error:_Missing_Qt_module_QTWEBKIT

-Steve

On Thu, Feb 23, 2017 at 5:02 AM, Jorge Quintero <[hidden email]> wrote:
Hello Slicer Developers,

I am Jorge Quintero and I am newbie in Slicer.

I am trying to build slicer for develope in Linux. I am following the
instructions of the documentation
(https://www.slicer.org/wiki/Documentation/Nightly/Developers/Build_Instructions#Ubuntu).

I done the following steps:

- Install Cmake 3.7-rc02 from
https://cmake.org/files/v3.7/cmake-3.7.2.tar.gz

- Install Git.

- Install SVN.

When I try to install QT using qt-easy-build, I get the next error:

make[2]: *** No hay ninguna regla para construir el objetivo
'../../WebCore/release/libwebcore.a', necesario para
'../../../../../../lib/libQtWebKit.so.4.9.4'.  Alto.
make[2]: se sale del directorio
'/home/jquintero/Descargas/qt-easy-build-4.8.7/qt-everywhere-opensource-src-4.8.7/src/3rdparty/webkit/Source/WebKit/qt'
Makefile.WebKit:135: fallo en las instrucciones para el objetivo
'sub-WebKit-qt-QtWebKit-pro-install_subtargets-ordered'
make[1]: *** [sub-WebKit-qt-QtWebKit-pro-install_subtargets-ordered] Error 2
make[1]: se sale del directorio
'/home/jquintero/Descargas/qt-easy-build-4.8.7/qt-everywhere-opensource-src-4.8.7/src/3rdparty/webkit/Source'
Makefile:693: fallo en las instrucciones para el objetivo
'sub-webkit-install_subtargets-ordered'
make: *** [sub-webkit-install_subtargets-ordered] Error 2

If I try to install from the download file
(http://download.qt-project.org/official_releases/qt/4.8/4.8.7/qt-everywhere-opensource-src-4.8.7.tar.gz
), I do not find the QT SDK necesary to build Slicer in the next steps.

Could someone help me?

Thanks.

Jorge




---------------------------------------------------------------------------------------------
ADVERTENCIA: Sobre la privacidad y cumplimiento de la Ley de Protección de Datos, acceda a http://www.iac.es/disclaimer.php
WARNING: For more information on privacy and fulfilment of the Law concerning the Protection of Data, consult http://www.iac.es/disclaimer.php?lang=en

_______________________________________________
slicer-devel mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
http://www.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/FAQ


_______________________________________________
slicer-devel mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
http://www.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/FAQ
Reply | Threaded
Open this post in threaded view
|

Re: Build Slicer in Linux.

Davide Punzo
In reply to this post by Jorge Quintero
Hi Jorge,

on ubuntu 16.04 and 16.10, you can also install qt4.8.7 (install also the
webkit)
just from the ubuntu repository (something like sudo apt-get install
qt4-dev-tools libqt4-dev libqt4-core libqt4-gui libqtwebkit-dev). Then when
you run the cmake in the Slicer build directory, you just give the path of
the installed qmake and it should work.

Cheers,

Davide.



--
View this message in context: http://slicer-devel.65872.n3.nabble.com/Build-Slicer-in-Linux-tp4038062p4038077.html
Sent from the slicer-devel mailing list archive at Nabble.com.
_______________________________________________
slicer-devel mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
http://www.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/FAQ
Reply | Threaded
Open this post in threaded view
|

Re: Build Slicer in Linux.

Davide Punzo
This post has NOT been accepted by the mailing list yet.
In reply to this post by Jorge Quintero
Hi Jorge,

on ubuntu 16.04 and 16.10, you can also install qt4.8.7 (install also the webkit)
just from the ubuntu repository (something like sudo apt-get install qt4-dev-tools libqt4-dev libqt4-core libqt4-gui libqtwebkit-dev). Then when you run the cmake in the Slicer build directory, you just give the path of the installed qmake and it should work.

Cheers,

Davide.
Reply | Threaded
Open this post in threaded view
|

Re: Build Slicer in Linux.

Steve Pieper-2
In reply to this post by Davide Punzo
Thanks for the info Davide - I added it to the wiki page:

https://www.slicer.org/wiki/Documentation/Nightly/Developers/Build_Instructions/Prerequisites#Qt

If anyone else see anything missing or out of date in the build instructions be sure to update the wiki accordingly or send a note to the list if you aren't sure.

-Steve

On Thu, Feb 23, 2017 at 2:30 PM, Davide Punzo <[hidden email]> wrote:
Hi Jorge,

on ubuntu 16.04 and 16.10, you can also install qt4.8.7 (install also the
webkit)
just from the ubuntu repository (something like sudo apt-get install
qt4-dev-tools libqt4-dev libqt4-core libqt4-gui libqtwebkit-dev). Then when
you run the cmake in the Slicer build directory, you just give the path of
the installed qmake and it should work.

Cheers,

Davide.



--
View this message in context: http://slicer-devel.65872.n3.nabble.com/Build-Slicer-in-Linux-tp4038062p4038077.html
Sent from the slicer-devel mailing list archive at Nabble.com.
_______________________________________________
slicer-devel mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
http://www.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/FAQ


_______________________________________________
slicer-devel mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
http://www.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/FAQ
Reply | Threaded
Open this post in threaded view
|

Re: Build Slicer in Linux.

Jorge Quintero

Thanks Davide.

I have got to build Slicer. Thank you very much.

Jorge


El 23/02/17 a las 19:42, Steve Pieper escribió:
Thanks for the info Davide - I added it to the wiki page:

https://www.slicer.org/wiki/Documentation/Nightly/Developers/Build_Instructions/Prerequisites#Qt

If anyone else see anything missing or out of date in the build instructions be sure to update the wiki accordingly or send a note to the list if you aren't sure.

-Steve

On Thu, Feb 23, 2017 at 2:30 PM, Davide Punzo <[hidden email]> wrote:
Hi Jorge,

on ubuntu 16.04 and 16.10, you can also install qt4.8.7 (install also the
webkit)
just from the ubuntu repository (something like sudo apt-get install
qt4-dev-tools libqt4-dev libqt4-core libqt4-gui libqtwebkit-dev). Then when
you run the cmake in the Slicer build directory, you just give the path of
the installed qmake and it should work.

Cheers,

Davide.



--
View this message in context: http://slicer-devel.65872.n3.nabble.com/Build-Slicer-in-Linux-tp4038062p4038077.html
Sent from the slicer-devel mailing list archive at Nabble.com.
_______________________________________________
slicer-devel mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
http://www.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/FAQ



_______________________________________________
slicer-devel mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
http://www.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/FAQ



ADVERTENCIA: Sobre la privacidad y cumplimiento de la Ley de Protección de Datos, acceda a http://www.iac.es/disclaimer.php
WARNING: For more information on privacy and fulfilment of the Law concerning the Protection of Data, consult http://www.iac.es/disclaimer.php?lang=en



_______________________________________________
slicer-devel mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
http://www.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/FAQ
Reply | Threaded
Open this post in threaded view
|

Re: Build Slicer in Linux.

Davide Punzo
You're welcome!

Ciao,

Davide.



--
View this message in context: http://slicer-devel.65872.n3.nabble.com/Build-Slicer-in-Linux-tp4038062p4038082.html
Sent from the slicer-devel mailing list archive at Nabble.com.
_______________________________________________
slicer-devel mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
http://www.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/FAQ
Reply | Threaded
Open this post in threaded view
|

Re: Build Slicer in Linux.

Davide Punzo
This post has NOT been accepted by the mailing list yet.
In reply to this post by Jorge Quintero
You're welcome!

Ciao,

Davide.