Re: slicer-devel Digest, Vol 143, Issue 39

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: slicer-devel Digest, Vol 143, Issue 39

Normand Robert
I have found that in Ubuntu 16.04.1 cmake fails in setting up the build with
-- Configuring Slicer revision [25300]
CMake Error at CMake/SlicerBlockFindQtAndCheckVersion.cmake:43 (message):
  error: Missing Qt module QTWEBKIT
Call Stack (most recent call first):
  CMake/SlicerBlockFindQtAndCheckVersion.cmake:88 (__SlicerBlockFindQtAndCheckVersion_find_qt)
  CMakeLists.txt:607 (include)

-- Configuring incomplete, errors occurred!

I get the same message whether I use Ubuntu's cmake or cmake 3.6.1 I built using the  system cmake (not bootstrap).

I have found that in Ubuntu 14.04.4 the current version of Slicer builds fine with Ubuntu packaged Qt4.8.6


On 2016-08-18 12:00 PM, [hidden email] wrote:
Send slicer-devel mailing list submissions to
	[hidden email]

To subscribe or unsubscribe via the World Wide Web, visit
	http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
or, via email, send a message with subject or body 'help' to
	[hidden email]

You can reach the person managing the list at
	[hidden email]

When replying, please edit your Subject line so it is more specific
than "Re: Contents of slicer-devel digest..."


Today's Topics:

   1. Slicer 3D build requirement Ubuntu 14.04.3 "Ubuntu 14.04 and
      above: Qt 4 == 4.8.7 MUST be used. " (Normand Robert)


_______________________________________________
slicer-devel mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
To unsubscribe: send email to [hidden email] with unsubscribe as the subject


-- 
Normand Robert PhD
Sunnybrook Health Sciences Centre
Room S632, 2075 Bayview Avenue, Toronto, ON M4N 3M5


_______________________________________________
slicer-devel mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
http://www.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/FAQ
Reply | Threaded
Open this post in threaded view
|

Re: slicer-devel Digest, Vol 143, Issue 39

Isaiah Norton-2
  error: Missing Qt module QTWEBKIT

This is not a cmake problem. Try installing 'libqt4-webkit'.

On Thu, Aug 18, 2016 at 4:15 PM, Normand Robert <[hidden email]> wrote:
I have found that in Ubuntu 16.04.1 cmake fails in setting up the build with
-- Configuring Slicer revision [25300]
CMake Error at CMake/SlicerBlockFindQtAndCheckVersion.cmake:43 (message):
  error: Missing Qt module QTWEBKIT
Call Stack (most recent call first):
  CMake/SlicerBlockFindQtAndCheckVersion.cmake:88 (__SlicerBlockFindQtAndCheckVersion_find_qt)
  CMakeLists.txt:607 (include)

-- Configuring incomplete, errors occurred!

I get the same message whether I use Ubuntu's cmake or cmake 3.6.1 I built using the  system cmake (not bootstrap).

I have found that in Ubuntu 14.04.4 the current version of Slicer builds fine with Ubuntu packaged Qt4.8.6


On 2016-08-18 12:00 PM, [hidden email] wrote:
Send slicer-devel mailing list submissions to
	[hidden email]

To subscribe or unsubscribe via the World Wide Web, visit
	http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
or, via email, send a message with subject or body 'help' to
	[hidden email]

You can reach the person managing the list at
	[hidden email]

When replying, please edit your Subject line so it is more specific
than "Re: Contents of slicer-devel digest..."


Today's Topics:

   1. Slicer 3D build requirement Ubuntu 14.04.3 "Ubuntu 14.04 and
      above: Qt 4 == 4.8.7 MUST be used. " (Normand Robert)


_______________________________________________
slicer-devel mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
To unsubscribe: send email to [hidden email] with unsubscribe as the subject


-- 
Normand Robert PhD
Sunnybrook Health Sciences Centre
Room S632, 2075 Bayview Avenue, Toronto, ON M4N 3M5


_______________________________________________
slicer-devel mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
http://www.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/FAQ


_______________________________________________
slicer-devel mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
http://www.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/FAQ
Reply | Threaded
Open this post in threaded view
|

Re: slicer-devel Digest, Vol 143, Issue 39

Normand Robert
In reply to this post by Normand Robert
My build problem Ubuntu 16.04.1 was fixed by adapting your advice. Thank you Isaiah.

sudo apt-get -y install libqtwebkit-dev

FYI: In order to build Slicer, the only other source code I downloaded and built was cmake because it was kinda broken on Debian derived distros for a long time.  I built cmake using Ubuntu's packaged cmake (not bootstrap because that results in a cmake with no ssl causing some downloads to fail).  Not sure I even need to do that anymore. We'll see about stability of Slicer on this OS in the weeks to come..

So Slicer builds fine with very little fuss if you install enough pkgs! I somehow missed this pkg :( while looking for webkit related pkgs when the cmake trouble first occurred arghhh. Did not need to build Qt either.

On 22/8/2016 14:03, Isaiah Norton wrote:
  error: Missing Qt module QTWEBKIT

This is not a cmake problem. Try installing 'libqt4-webkit'.

On Thu, Aug 18, 2016 at 4:15 PM, Normand Robert <[hidden email]> wrote:
I have found that in Ubuntu 16.04.1 cmake fails in setting up the build with
-- Configuring Slicer revision [25300]
CMake Error at CMake/SlicerBlockFindQtAndCheckVersion.cmake:43 (message):
  error: Missing Qt module QTWEBKIT
Call Stack (most recent call first):
  CMake/SlicerBlockFindQtAndCheckVersion.cmake:88 (__SlicerBlockFindQtAndCheckVersion_find_qt)
  CMakeLists.txt:607 (include)

-- Configuring incomplete, errors occurred!

I get the same message whether I use Ubuntu's cmake or cmake 3.6.1 I built using the  system cmake (not bootstrap).

I have found that in Ubuntu 14.04.4 the current version of Slicer builds fine with Ubuntu packaged Qt4.8.6


On 2016-08-18 12:00 PM, [hidden email] wrote:
Send slicer-devel mailing list submissions to
	[hidden email]

To subscribe or unsubscribe via the World Wide Web, visit
	http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
or, via email, send a message with subject or body 'help' to
	[hidden email]

You can reach the person managing the list at
	[hidden email]

When replying, please edit your Subject line so it is more specific
than "Re: Contents of slicer-devel digest..."
Today's Topics:

   1. Slicer 3D build requirement Ubuntu 14.04.3 "Ubuntu 14.04 and
      above: Qt 4 == 4.8.7 MUST be used. " (Normand Robert)
_______________________________________________
slicer-devel mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
To unsubscribe: send email to [hidden email] with unsubscribe as the subject

-- 
Normand Robert PhD
Sunnybrook Health Sciences Centre
Room S632, 2075 Bayview Avenue, Toronto, ON M4N 3M5

_______________________________________________ slicer-devel mailing list [hidden email] http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel To unsubscribe: send email to [hidden email] with unsubscribe as the subject http://www.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/FAQ

-- 
Normand Robert PhD 
Sunnybrook Health Sciences Centre 
Room S632, 2075 Bayview Avenue, 
Toronto, ON M4N 3M5 

_______________________________________________
slicer-devel mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
http://www.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/FAQ
Reply | Threaded
Open this post in threaded view
|

Re: slicer-devel Digest, Vol 143, Issue 39

Steve Pieper-2
That's great to hear Nornand - it would be great if you could tweak the wiki with the extra key bits of info to help out the next person.

https://www.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/Build_Instructions#Ubuntu

Best,
Steve

On Mon, Aug 22, 2016 at 3:37 PM, Normand Robert <[hidden email]> wrote:
My build problem Ubuntu 16.04.1 was fixed by adapting your advice. Thank you Isaiah.

sudo apt-get -y install libqtwebkit-dev

FYI: In order to build Slicer, the only other source code I downloaded and built was cmake because it was kinda broken on Debian derived distros for a long time.  I built cmake using Ubuntu's packaged cmake (not bootstrap because that results in a cmake with no ssl causing some downloads to fail).  Not sure I even need to do that anymore. We'll see about stability of Slicer on this OS in the weeks to come..

So Slicer builds fine with very little fuss if you install enough pkgs! I somehow missed this pkg :( while looking for webkit related pkgs when the cmake trouble first occurred arghhh. Did not need to build Qt either.

On 22/8/2016 14:03, Isaiah Norton wrote:
  error: Missing Qt module QTWEBKIT

This is not a cmake problem. Try installing 'libqt4-webkit'.

On Thu, Aug 18, 2016 at 4:15 PM, Normand Robert <[hidden email]> wrote:
I have found that in Ubuntu 16.04.1 cmake fails in setting up the build with
-- Configuring Slicer revision [25300]
CMake Error at CMake/SlicerBlockFindQtAndCheckVersion.cmake:43 (message):
  error: Missing Qt module QTWEBKIT
Call Stack (most recent call first):
  CMake/SlicerBlockFindQtAndCheckVersion.cmake:88 (__SlicerBlockFindQtAndCheckVersion_find_qt)
  CMakeLists.txt:607 (include)

-- Configuring incomplete, errors occurred!

I get the same message whether I use Ubuntu's cmake or cmake 3.6.1 I built using the  system cmake (not bootstrap).

I have found that in Ubuntu 14.04.4 the current version of Slicer builds fine with Ubuntu packaged Qt4.8.6


On 2016-08-18 12:00 PM, [hidden email] wrote:
Send slicer-devel mailing list submissions to
	[hidden email]

To subscribe or unsubscribe via the World Wide Web, visit
	http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
or, via email, send a message with subject or body 'help' to
	[hidden email]

You can reach the person managing the list at
	[hidden email]

When replying, please edit your Subject line so it is more specific
than "Re: Contents of slicer-devel digest..."
Today's Topics:

   1. Slicer 3D build requirement Ubuntu 14.04.3 "Ubuntu 14.04 and
      above: Qt 4 == 4.8.7 MUST be used. " (Normand Robert)
_______________________________________________
slicer-devel mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
To unsubscribe: send email to [hidden email] with unsubscribe as the subject

-- 
Normand Robert PhD
Sunnybrook Health Sciences Centre
Room S632, 2075 Bayview Avenue, Toronto, ON M4N 3M5

_______________________________________________ slicer-devel mailing list [hidden email] http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel To unsubscribe: send email to [hidden email] with unsubscribe as the subject http://www.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/FAQ

-- 
Normand Robert PhD 
Sunnybrook Health Sciences Centre 
Room S632, 2075 Bayview Avenue, 
Toronto, ON M4N 3M5 

_______________________________________________
slicer-devel mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
http://www.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/FAQ


_______________________________________________
slicer-devel mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
http://www.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/FAQ
Reply | Threaded
Open this post in threaded view
|

Re: slicer-devel Digest, Vol 143, Issue 39

Fernando
I'm building Slicer for the first time because why not and also got this
error on Ubuntu 16.04.

I have updated the wiki:
https://www.slicer.org/wiki/Documentation/Nightly/Developers/Build_Instructions#error:_Missing_Qt_module_QTWEBKIT


Best,
Fernando



--
View this message in context: http://slicer-devel.65872.n3.nabble.com/Re-slicer-devel-Digest-Vol-143-Issue-39-tp4037122p4038063.html
Sent from the slicer-devel mailing list archive at Nabble.com.
_______________________________________________
slicer-devel mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
http://www.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/FAQ
Reply | Threaded
Open this post in threaded view
|

Re: slicer-devel Digest, Vol 143, Issue 39

Fernando
This post has NOT been accepted by the mailing list yet.
In reply to this post by Steve Pieper-2
I'm building Slicer for the first time because why not and also got this error on Ubuntu 16.04.

I have updated the wiki: https://www.slicer.org/wiki/Documentation/Nightly/Developers/Build_Instructions#error:_Missing_Qt_module_QTWEBKIT


Best,
Fernando