Slice Intersections not working after loading a scene

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Slice Intersections not working after loading a scene

Tamas Ungi

Dear Developers,

 

I would appreciate help with this issue very much. My users are working on spine MRI data, and without the slice intersections, it's almost impossible to tell which vertebra is visible in the axial slice.

 

I reported the issue in Mantis, ID= 0001112.

 

After a saved scene is loaded, the Slice Intersections (from Manipulate Slice Views panel) function is not working. Slice intersections are not shown in either of the three slice views.

 

I have tested on Windows, with Slicer versions 3.6.2-RC2 and 3.6.3-RC2 (Feb 24 revision).

 

Thank you,

Tamas

 


_______________________________________________
slicer-devel mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: Slice Intersections not working after loading a scene

pieper
Administrator
Hi Tamas -

Thanks for the reminder - this issue has been bugging me for a while
too, so I took another look and I think the fix was pretty simple.  Can
you try the latest trunk or tomorrow's nightly and let me know?  Note
that the state of the intersection display is not restored on scene
load, but if you turn it on manually the intersection lines should now
display and update properly.

If it works we can apply this for a future 3.6.4 release.

http://viewvc.slicer.org/viewcvs.cgi?rev=16142&view=rev

I also put the fix in slicer4.

-Steve



On 03/02/2011 04:06 PM, Tamas Ungi wrote:

> Dear Developers,
>
> I would appreciate help with this issue very much. My users are working
> on spine MRI data, and without the slice intersections, it's almost
> impossible to tell which vertebra is visible in the axial slice.
>
> I reported the issue in Mantis, ID= 0001112.
>
> After a saved scene is loaded, the Slice Intersections (from Manipulate
> Slice Views panel) function is not working. Slice intersections are not
> shown in either of the three slice views.
>
> I have tested on Windows, with Slicer versions 3.6.2-RC2 and 3.6.3-RC2
> (Feb 24 revision).
>
> Thank you,
>
> Tamas
>
>
>
> _______________________________________________
> slicer-devel mailing list
> [hidden email]
> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
> To unsubscribe: send email to [hidden email] with unsubscribe as the subject
_______________________________________________
slicer-devel mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: Slice Intersections not working after loading a scene

Tamas Ungi
Thank you very much Steve!
I checked in the nightly (2011-03-04) and it's working.

What is the recommended way to deploy this fix? I have tried my module dll
file (PerkStationModule build with Slicer-3-6-2-RC2), and it's working with
this nightly build. Is it safe to use this nightly build for clinical IGT
procedures, or should I create a 3.6.2 installer after updating this one tcl
file?
(They will need it by the end of next week, I guess there won't be any new
stable release by then.)

Thanks,
Tamas


-----Original Message-----
From: Steve Pieper [mailto:[hidden email]]
Sent: Thursday, March 03, 2011 8:36 AM
To: Tamas Ungi
Cc: [hidden email]
Subject: Re: [slicer-devel] Slice Intersections not working after loading a
scene

Hi Tamas -

Thanks for the reminder - this issue has been bugging me for a while too, so
I took another look and I think the fix was pretty simple.  Can you try the
latest trunk or tomorrow's nightly and let me know?  Note that the state of
the intersection display is not restored on scene load, but if you turn it
on manually the intersection lines should now display and update properly.

If it works we can apply this for a future 3.6.4 release.

http://viewvc.slicer.org/viewcvs.cgi?rev=16142&view=rev

I also put the fix in slicer4.

-Steve



On 03/02/2011 04:06 PM, Tamas Ungi wrote:

> Dear Developers,
>
> I would appreciate help with this issue very much. My users are
> working on spine MRI data, and without the slice intersections, it's
> almost impossible to tell which vertebra is visible in the axial slice.
>
> I reported the issue in Mantis, ID= 0001112.
>
> After a saved scene is loaded, the Slice Intersections (from
> Manipulate Slice Views panel) function is not working. Slice
> intersections are not shown in either of the three slice views.
>
> I have tested on Windows, with Slicer versions 3.6.2-RC2 and 3.6.3-RC2
> (Feb 24 revision).
>
> Thank you,
>
> Tamas
>
>
>
> _______________________________________________
> slicer-devel mailing list
> [hidden email]
> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
> To unsubscribe: send email to
> [hidden email] with unsubscribe as the
> subject

_______________________________________________
slicer-devel mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
Reply | Threaded
Open this post in threaded view
|

Re: Slice Intersections not working after loading a scene

pieper
Administrator
Glad that worked!

You are right, this fix won't be in a stable release until sometime in
the future -- it missed the 3.6.3 cutoff, so it will be in the nightlies
for a while just so we can see if there are any unintended side effects.

Realistically for your case, the fix probably just involves dropping in
the latest version of ModelSWidget.tcl to your existing build (certainly
you want to doublecheck that it works, but it it appears to be working I
don't forsee any side effects).

http://viewvc.slicer.org/viewcvs.cgi/trunk/Base/GUI/Tcl/ModelSWidget.tcl?rev=16143&view=log

Best,
Steve

p.s. the 3.6.3 releases are just finishing up building now and I plan to
put them directly onto the slicer.org download site.

On 03/04/2011 04:51 PM, Tamas Ungi wrote:

> Thank you very much Steve!
> I checked in the nightly (2011-03-04) and it's working.
>
> What is the recommended way to deploy this fix? I have tried my module dll
> file (PerkStationModule build with Slicer-3-6-2-RC2), and it's working with
> this nightly build. Is it safe to use this nightly build for clinical IGT
> procedures, or should I create a 3.6.2 installer after updating this one tcl
> file?
> (They will need it by the end of next week, I guess there won't be any new
> stable release by then.)
>
> Thanks,
> Tamas
>
>
> -----Original Message-----
> From: Steve Pieper [mailto:[hidden email]]
> Sent: Thursday, March 03, 2011 8:36 AM
> To: Tamas Ungi
> Cc: [hidden email]
> Subject: Re: [slicer-devel] Slice Intersections not working after loading a
> scene
>
> Hi Tamas -
>
> Thanks for the reminder - this issue has been bugging me for a while too, so
> I took another look and I think the fix was pretty simple.  Can you try the
> latest trunk or tomorrow's nightly and let me know?  Note that the state of
> the intersection display is not restored on scene load, but if you turn it
> on manually the intersection lines should now display and update properly.
>
> If it works we can apply this for a future 3.6.4 release.
>
> http://viewvc.slicer.org/viewcvs.cgi?rev=16142&view=rev
>
> I also put the fix in slicer4.
>
> -Steve
>
>
>
> On 03/02/2011 04:06 PM, Tamas Ungi wrote:
>> Dear Developers,
>>
>> I would appreciate help with this issue very much. My users are
>> working on spine MRI data, and without the slice intersections, it's
>> almost impossible to tell which vertebra is visible in the axial slice.
>>
>> I reported the issue in Mantis, ID= 0001112.
>>
>> After a saved scene is loaded, the Slice Intersections (from
>> Manipulate Slice Views panel) function is not working. Slice
>> intersections are not shown in either of the three slice views.
>>
>> I have tested on Windows, with Slicer versions 3.6.2-RC2 and 3.6.3-RC2
>> (Feb 24 revision).
>>
>> Thank you,
>>
>> Tamas
>>
>>
>>
>> _______________________________________________
>> slicer-devel mailing list
>> [hidden email]
>> http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
>> To unsubscribe: send email to
>> [hidden email] with unsubscribe as the
>> subject
>
_______________________________________________
slicer-devel mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
To unsubscribe: send email to [hidden email] with unsubscribe as the subject