SlicerIGT setup: Problems with VirtualStreamCapture and VirtualVolumeReconstructor in Plus Remote

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

SlicerIGT setup: Problems with VirtualStreamCapture and VirtualVolumeReconstructor in Plus Remote

Seyed-Ahmad Ahmadi
Dear all,

not sure whether SlicerIGT problems also need to get reported in the Slicer mailing list, but I'm going to try it here...

I have exactly the setup from the following config file (shipped with PLUS 2.4.0.5052):
PlusDeviceSet_Server_Ultrasonix_L14-5_Ascension3DG_calibrated.xml

I managed to get everything streaming in Slicer (4.6.2) using SlicerIGT, I get the tracked real-time ultrasound, I even managed to attach the Sonix L14-5 GPS model (stl file) attached to the ultrasound image, as far as I can tell the calibration from the config file is correct as well... it all works really beautifully. :)

However, the "Plus Remote" module does not allow me to record sweeps or reconstruct them.
My IGTLConnector gets select automatically, however, the drop-down menues for the "Capture Device ID" or the "Reconstructor Device ID" cannot be clicked (not greyed out, but not clickable). Maybe that's an indication for the problem?

As said, I used the config file "PlusDeviceSet_Server_Ultrasonix_L14-5_Ascension3DG_calibrated.xml", and that contains both a Type="VirtualDiscCapture" and a Type="VirtualVolumeReconstructor" device. Still though, none of them are reachable through the Plus Remote module.

These are the error messages

020717_175801.444|INFO|203.024000| vtkPlusStartStopRecordingCommand::Execute:| in ..\..\..\PlusLib\src\PlusServer\Commands\vtkPlusStartStopRecordingCommand.cxx(179)
020717_175801.444|ERROR|203.024000| No VirtualStreamCapture has been found| in ..\..\..\PlusLib\src\PlusServer\Commands\vtkPlusStartStopRecordingCommand.cxx(169)
020717_175801.444|ERROR|203.024000| Command execution failed| in ..\..\..\PlusLib\src\PlusServer\vtkPlusCommandProcessor.cxx(161)
020717_180101.354|ERROR|382.934000| No VirtualVolumeReconstructor has been found| in ..\..\..\PlusLib\src\PlusServer\Commands\vtkPlusReconstructVolumeCommand.cxx(463)
020717_180101.354|ERROR|382.934000| Command execution failed| in ..\..\..\PlusLib\src\PlusServer\vtkPlusCommandProcessor.cxx(161)

Do you have any suggestions on how to fix this?

Thanks and Cheers,
Ahmad Ahmadi

_______________________________________________
slicer-devel mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
http://www.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/FAQ
Reply | Threaded
Open this post in threaded view
|

Re: SlicerIGT setup: Problems with VirtualStreamCapture and VirtualVolumeReconstructor in Plus Remote

lasso2

Please attach your Plus configuration file.

 

Andras

 

From: [hidden email]
Sent: Tuesday, February 7, 2017 1:18 PM
To: [hidden email]
Subject: [slicer-devel] SlicerIGT setup: Problems with VirtualStreamCapture and VirtualVolumeReconstructor in Plus Remote

 

Dear all,

not sure whether SlicerIGT problems also need to get reported in the Slicer mailing list, but I'm going to try it here...

I have exactly the setup from the following config file (shipped with PLUS 2.4.0.5052):
PlusDeviceSet_Server_Ultrasonix_L14-5_Ascension3DG_calibrated.xml

I managed to get everything streaming in Slicer (4.6.2) using SlicerIGT, I get the tracked real-time ultrasound, I even managed to attach the Sonix L14-5 GPS model (stl file) attached to the ultrasound image, as far as I can tell the calibration from the config file is correct as well... it all works really beautifully. :)

However, the "Plus Remote" module does not allow me to record sweeps or reconstruct them.
My IGTLConnector gets select automatically, however, the drop-down menues for the "Capture Device ID" or the "Reconstructor Device ID" cannot be clicked (not greyed out, but not clickable). Maybe that's an indication for the problem?

As said, I used the config file "PlusDeviceSet_Server_Ultrasonix_L14-5_Ascension3DG_calibrated.xml", and that contains both a Type="VirtualDiscCapture" and a Type="VirtualVolumeReconstructor" device. Still though, none of them are reachable through the Plus Remote module.

These are the error messages

020717_175801.444|INFO|203.024000| vtkPlusStartStopRecordingCommand::Execute:| in ..\..\..\PlusLib\src\PlusServer\Commands\vtkPlusStartStopRecordingCommand.cxx(179)
020717_175801.444|ERROR|203.024000| No VirtualStreamCapture has been found| in ..\..\..\PlusLib\src\PlusServer\Commands\vtkPlusStartStopRecordingCommand.cxx(169)
020717_175801.444|ERROR|203.024000| Command execution failed| in ..\..\..\PlusLib\src\PlusServer\vtkPlusCommandProcessor.cxx(161)
020717_180101.354|ERROR|382.934000| No VirtualVolumeReconstructor has been found| in ..\..\..\PlusLib\src\PlusServer\Commands\vtkPlusReconstructVolumeCommand.cxx(463)
020717_180101.354|ERROR|382.934000| Command execution failed| in ..\..\..\PlusLib\src\PlusServer\vtkPlusCommandProcessor.cxx(161)

Do you have any suggestions on how to fix this?

Thanks and Cheers,
Ahmad Ahmadi

_______________________________________________
slicer-devel mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
http://www.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/FAQ
Reply | Threaded
Open this post in threaded view
|

Re: SlicerIGT setup: Problems with VirtualStreamCapture and VirtualVolumeReconstructor in Plus Remote

Adam Rankin-2

If you grabbed the latest, the VirtualDiscCapture device type  has been renamed to VirtualCapture.

 

Adam

 

From: slicer-devel [mailto:[hidden email]] On Behalf Of Andras Lasso
Sent: Tuesday, February 7, 2017 1:30 PM
To: Seyed-Ahmad Ahmadi <[hidden email]>; SPL Slicer Devel <[hidden email]>
Subject: Re: [slicer-devel] SlicerIGT setup: Problems with VirtualStreamCapture and VirtualVolumeReconstructor in Plus Remote

 

Please attach your Plus configuration file.

 

Andras

 

From: [hidden email]
Sent: Tuesday, February 7, 2017 1:18 PM
To: [hidden email]
Subject: [slicer-devel] SlicerIGT setup: Problems with VirtualStreamCapture and VirtualVolumeReconstructor in Plus Remote

 

Dear all,

not sure whether SlicerIGT problems also need to get reported in the Slicer mailing list, but I'm going to try it here...

I have exactly the setup from the following config file (shipped with PLUS 2.4.0.5052):
PlusDeviceSet_Server_Ultrasonix_L14-5_Ascension3DG_calibrated.xml

I managed to get everything streaming in Slicer (4.6.2) using SlicerIGT, I get the tracked real-time ultrasound, I even managed to attach the Sonix L14-5 GPS model (stl file) attached to the ultrasound image, as far as I can tell the calibration from the config file is correct as well... it all works really beautifully. :)

However, the "Plus Remote" module does not allow me to record sweeps or reconstruct them.

My IGTLConnector gets select automatically, however, the drop-down menues for the "Capture Device ID" or the "Reconstructor Device ID" cannot be clicked (not greyed out, but not clickable). Maybe that's an indication for the problem?

As said, I used the config file "PlusDeviceSet_Server_Ultrasonix_L14-5_Ascension3DG_calibrated.xml", and that contains both a Type="VirtualDiscCapture" and a Type="VirtualVolumeReconstructor" device. Still though, none of them are reachable through the Plus Remote module.

These are the error messages


020717_175801.444|INFO|203.024000| vtkPlusStartStopRecordingCommand::Execute:| in ..\..\..\PlusLib\src\PlusServer\Commands\vtkPlusStartStopRecordingCommand.cxx(179)
020717_175801.444|ERROR|203.024000| No VirtualStreamCapture has been found| in ..\..\..\PlusLib\src\PlusServer\Commands\vtkPlusStartStopRecordingCommand.cxx(169)
020717_175801.444|ERROR|203.024000| Command execution failed| in ..\..\..\PlusLib\src\PlusServer\vtkPlusCommandProcessor.cxx(161)
020717_180101.354|ERROR|382.934000| No VirtualVolumeReconstructor has been found| in ..\..\..\PlusLib\src\PlusServer\Commands\vtkPlusReconstructVolumeCommand.cxx(463)
020717_180101.354|ERROR|382.934000| Command execution failed| in ..\..\..\PlusLib\src\PlusServer\vtkPlusCommandProcessor.cxx(161)

Do you have any suggestions on how to fix this?

Thanks and Cheers,

Ahmad Ahmadi


_______________________________________________
slicer-devel mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
http://www.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/FAQ
Reply | Threaded
Open this post in threaded view
|

Re: SlicerIGT setup: Problems with VirtualStreamCapture and VirtualVolumeReconstructor in Plus Remote

Adam Rankin-2
In reply to this post by lasso2

Identified a bug in SlicerIGT, see https://github.com/SlicerIGT/SlicerIGT/pull/115 for resolution.

 

Adam

 

From: slicer-devel [mailto:[hidden email]] On Behalf Of Andras Lasso
Sent: Tuesday, February 7, 2017 1:30 PM
To: Seyed-Ahmad Ahmadi <[hidden email]>; SPL Slicer Devel <[hidden email]>
Subject: Re: [slicer-devel] SlicerIGT setup: Problems with VirtualStreamCapture and VirtualVolumeReconstructor in Plus Remote

 

Please attach your Plus configuration file.

 

Andras

 

From: [hidden email]
Sent: Tuesday, February 7, 2017 1:18 PM
To: [hidden email]
Subject: [slicer-devel] SlicerIGT setup: Problems with VirtualStreamCapture and VirtualVolumeReconstructor in Plus Remote

 

Dear all,

not sure whether SlicerIGT problems also need to get reported in the Slicer mailing list, but I'm going to try it here...

I have exactly the setup from the following config file (shipped with PLUS 2.4.0.5052):
PlusDeviceSet_Server_Ultrasonix_L14-5_Ascension3DG_calibrated.xml

I managed to get everything streaming in Slicer (4.6.2) using SlicerIGT, I get the tracked real-time ultrasound, I even managed to attach the Sonix L14-5 GPS model (stl file) attached to the ultrasound image, as far as I can tell the calibration from the config file is correct as well... it all works really beautifully. :)

However, the "Plus Remote" module does not allow me to record sweeps or reconstruct them.

My IGTLConnector gets select automatically, however, the drop-down menues for the "Capture Device ID" or the "Reconstructor Device ID" cannot be clicked (not greyed out, but not clickable). Maybe that's an indication for the problem?

As said, I used the config file "PlusDeviceSet_Server_Ultrasonix_L14-5_Ascension3DG_calibrated.xml", and that contains both a Type="VirtualDiscCapture" and a Type="VirtualVolumeReconstructor" device. Still though, none of them are reachable through the Plus Remote module.

These are the error messages


020717_175801.444|INFO|203.024000| vtkPlusStartStopRecordingCommand::Execute:| in ..\..\..\PlusLib\src\PlusServer\Commands\vtkPlusStartStopRecordingCommand.cxx(179)
020717_175801.444|ERROR|203.024000| No VirtualStreamCapture has been found| in ..\..\..\PlusLib\src\PlusServer\Commands\vtkPlusStartStopRecordingCommand.cxx(169)
020717_175801.444|ERROR|203.024000| Command execution failed| in ..\..\..\PlusLib\src\PlusServer\vtkPlusCommandProcessor.cxx(161)
020717_180101.354|ERROR|382.934000| No VirtualVolumeReconstructor has been found| in ..\..\..\PlusLib\src\PlusServer\Commands\vtkPlusReconstructVolumeCommand.cxx(463)
020717_180101.354|ERROR|382.934000| Command execution failed| in ..\..\..\PlusLib\src\PlusServer\vtkPlusCommandProcessor.cxx(161)

Do you have any suggestions on how to fix this?

Thanks and Cheers,

Ahmad Ahmadi


_______________________________________________
slicer-devel mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
http://www.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/FAQ
Reply | Threaded
Open this post in threaded view
|

Re: SlicerIGT setup: Problems with VirtualStreamCapture and VirtualVolumeReconstructor in Plus Remote

Seyed-Ahmad Ahmadi
In reply to this post by lasso2
The config file is now attached.
@Adam: So - For the PlusRemote.py file, I just need to replace the VirtualDiscCapture with VirtualCapture as indicated in the link you sent... Would that also fix the problem with the VirtualVolumeReconstructor? Or has a rename occurred there too?

Cheers,
Ahmad



On Tue, Feb 7, 2017 at 7:37 PM, Adam Rankin <[hidden email]> wrote:

Identified a bug in SlicerIGT, see https://github.com/SlicerIGT/SlicerIGT/pull/115 for resolution.

 

Adam

 

From: slicer-devel [mailto:[hidden email]] On Behalf Of Andras Lasso
Sent: Tuesday, February 7, 2017 1:30 PM
To: Seyed-Ahmad Ahmadi <[hidden email]>; SPL Slicer Devel <[hidden email]>
Subject: Re: [slicer-devel] SlicerIGT setup: Problems with VirtualStreamCapture and VirtualVolumeReconstructor in Plus Remote

 

Please attach your Plus configuration file.

 

Andras

 

From: [hidden email]
Sent: Tuesday, February 7, 2017 1:18 PM
To: [hidden email]
Subject: [slicer-devel] SlicerIGT setup: Problems with VirtualStreamCapture and VirtualVolumeReconstructor in Plus Remote

 

Dear all,

not sure whether SlicerIGT problems also need to get reported in the Slicer mailing list, but I'm going to try it here...

I have exactly the setup from the following config file (shipped with PLUS 2.4.0.5052):
PlusDeviceSet_Server_Ultrasonix_L14-5_Ascension3DG_calibrated.xml

I managed to get everything streaming in Slicer (4.6.2) using SlicerIGT, I get the tracked real-time ultrasound, I even managed to attach the Sonix L14-5 GPS model (stl file) attached to the ultrasound image, as far as I can tell the calibration from the config file is correct as well... it all works really beautifully. :)

However, the "Plus Remote" module does not allow me to record sweeps or reconstruct them.

My IGTLConnector gets select automatically, however, the drop-down menues for the "Capture Device ID" or the "Reconstructor Device ID" cannot be clicked (not greyed out, but not clickable). Maybe that's an indication for the problem?

As said, I used the config file "PlusDeviceSet_Server_Ultrasonix_L14-5_Ascension3DG_calibrated.xml", and that contains both a Type="VirtualDiscCapture" and a Type="VirtualVolumeReconstructor" device. Still though, none of them are reachable through the Plus Remote module.

These are the error messages


020717_175801.444|INFO|203.024000| vtkPlusStartStopRecordingCommand::Execute:| in ..\..\..\PlusLib\src\PlusServer\Commands\vtkPlusStartStopRecordingCommand.cxx(179)
020717_175801.444|ERROR|203.024000| No VirtualStreamCapture has been found| in ..\..\..\PlusLib\src\PlusServer\Commands\vtkPlusStartStopRecordingCommand.cxx(169)
020717_175801.444|ERROR|203.024000| Command execution failed| in ..\..\..\PlusLib\src\PlusServer\vtkPlusCommandProcessor.cxx(161)
020717_180101.354|ERROR|382.934000| No VirtualVolumeReconstructor has been found| in ..\..\..\PlusLib\src\PlusServer\Commands\vtkPlusReconstructVolumeCommand.cxx(463)
020717_180101.354|ERROR|382.934000| Command execution failed| in ..\..\..\PlusLib\src\PlusServer\vtkPlusCommandProcessor.cxx(161)

Do you have any suggestions on how to fix this?

Thanks and Cheers,

Ahmad Ahmadi



_______________________________________________
slicer-devel mailing list
[hidden email]
http://massmail.spl.harvard.edu/mailman/listinfo/slicer-devel
To unsubscribe: send email to [hidden email] with unsubscribe as the subject
http://www.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/FAQ

PlusDeviceSet_Server_Ultrasonix_L14-5_Ascension3DG_calibrated.xml (6K) Download Attachment